Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 71

Thread: Tim Holtz with stamping platform at CHA

  1. #61
    Join Date
    Jul 2008
    Location
    South Wales
    Posts
    6,423
    Post Thanks / Like

    Default

    Quote Originally Posted by ScannCutter View Post
    I read the other day where someone had a similar problem and it turned out there was a fault in hinge, so Tonic replaced it. You can go either to the Tonic Studios website and send them a support ticket or go their Facebook page and send a private message. Their customer service is excellent.
    Yes, I read about that too and also someone had a platform that had been warped somehow and it was twisted and that was replaced as well. I know through personal experience that Tonic have brilliant customer service. It's also better to go through them rather than who you bought it from - Tonic prefer to deal with problems themselves. I suppose that's the only way they can ensure complaints are dealt with to the highest standard.
    Thanks 1 Member(s) thanked for this post
    Likes 1 Member(s) liked this post
     
    http://pamelaspages.blogspot.com/

  2. #62
    Join Date
    Jul 2010
    Posts
    4,936
    Post Thanks / Like

    Default

    Thank you ScannCutter and Pamela will have another go later today with different stamps but don't hold much hope lol. I'll get in touch with them later.

    It's quite noticeable that it hasn't stamped properly.
    Thanks 1 Member(s) thanked for this post
     
    I love flowers

  3. #63
    Join Date
    Apr 2010
    Location
    Cheltenham
    Posts
    1,831
    Post Thanks / Like

    Default

    Just tried mine out and am very pleased with it. It worked very well with rubber stamps, I can't say about clear ones as I don't have any. So sorry Waterlily that you are having trouble with yours, but perhaps with contacting Tonic themselves they will be able to sort it out.

  4. #64
    Join Date
    Jul 2010
    Posts
    4,936
    Post Thanks / Like

    Default

    Thanks Tricia, I've done a support ticket and had an automated reply (I think lol) so hopefully will hear from them after the weekend. Wasn't sure whether to go to the UK one or the USA one so went to the UK one.
    I love flowers

  5. #65
    Join Date
    Apr 2010
    Location
    Cheltenham
    Posts
    1,831
    Post Thanks / Like

    Default

    Update to my having a go, I used an unmounted rubber stamp. Side used was clear as the stamp is about the same thickness as a clear one. I gave it a light spraying of 3M spray mount and it worked okay. Left behind some sticky residue but I managed to remove that using a baby wipe.

    I too would have contacted the Tonic UK for their help.

  6. #66
    Join Date
    Apr 2011
    Posts
    230
    Post Thanks / Like

    Default

    Mine arrived this morning, now need time to try it out, hope that those waiting for theirs also got a call from the postie today

  7. #67
    Join Date
    Jan 2009
    Location
    market harborough
    Posts
    353
    Post Thanks / Like

    Default

    Mine arrived today.I have only tried one stamp but it stamped well which will be a help for my hands.

  8. #68
    Join Date
    Jun 2008
    Posts
    4,520
    Post Thanks / Like

    Default

    Still not even a sniff of mine yet here.

  9. #69
    Join Date
    Apr 2010
    Location
    Cheltenham
    Posts
    1,831
    Post Thanks / Like

    Default

    How did you get on Waterlily, have Tonic responded to your support ticket?

  10. #70
    Join Date
    Jul 2010
    Posts
    4,936
    Post Thanks / Like

    Default

    I had an email yesterday tricia, they want me to send pics. I've got a feeling now that it's the stamps I used. Tried a couple more and they were fine but also had a problem with the bottom layer of a layered stamp. Think that was the stamp too.
    I love flowers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •